Сегодня

Варианты интеграции онлайн-кассы под ФЗ-54 с конфигурацией Управление Торговлей 10.2

Вопрос об интеграции онлайн-кассы, работающей по ФЗ-54 в связке с программой 1С: Управление торговлей 8.х, которая была снята с поддержки и длительное время не обновлялась и, вероятнее всего, была сконфигурирована (доработана) под "заказчика" актуален как никогда. Это вызвано тем, что в 2021 году в кассовых чеках, помимо количественно-суммовой информации, необходимо будет отображать и информацию о наименовании товара. Вариантов решения здесь несколько. Специалисты предлагают целый ряд подходов к решению задачи. Самое главное – выбрать наиболее оптимальный путь решения проблемы.

Первый вариант – доработка конфигурации с внедрением в программу обработки обслуживания "АТОЛ ККТ с передачей данных". Здесь все будет упираться в стоимость и качество доработки и внедрения.

подслушано в Прибитюжье:
В селе Верхняя Тойда Аннинского района планируется построить новый Дом культуры на 120 мест
Второй вариант - приобрести готовую разработку от фрилансера. Автор данной статьи посмотрел на одну из таких обработок, которая "выложена" на Инфостарте: цена и тяжеловесность решения с неопределенностью в плане дальнейшей поддержки, а также проблемы с надежностью проброса портов делают сомнительным выбор данного варианта.

Третий вариант - на локальной машине развернуть драйвер ККМ с использованием программы для печати чеков Александра Гельмера. С точки зрения трудоемкости внедрения и стоимости вариант не самый плохой. Но у пользователя отсутствует контроль над тем, что происходит на локальной машине. В случае сбоя сложно будет оперативно найти и исправить причину возникновения нештатной ситуации – в 1С, на сервере, на локальной машине, в драйвере, на кассе.

Четвертый вариант связан с приобретением и развертыванием на кассе базовой 1С Розница 2.2. В конфигурации "Конвертация данных" необходимо будет сделать файл обмена для "Универсального обмена в формате XML". Вариант крайне дешевый. Проблема с поддержкой в случае изменения законодательства переносится на фирму 1С, накатывай своевременно обновления и нет проблем. Большой минус этого варианта – чрезмерно сложный алгоритм работы пользователя.

подслушано в Прибитюжье:
После перепрофилирования Аннинский спиртзавод будет выпускать технический спирт и дрожжи
Автор статьи на протяжении 10 лет сопровождает в одной из торговых компаний работу программы "Управление торговлей" редакции 10.3.13.2 на платформе 8.2.11.236 и внес в нее достаточно много изменений. В связи с релизом из далекого прошлого и существенной доработкой конфигурации было принято решение отказаться от идеи поднять релиз (после сравнения конфигураций) хотя бы до редакции 10.3.53.2 (платформы до 8.2.19.130) и выбран вариант связки двух программ - "слона" 1С и "моськи" Лайтик-ККМ.

Онлайн-кассы

Работа программы "Лайтик-ККМ" из под "1С: Управление торговлей"

- за 500 рублей приобретена лицензия на право использования программы Лайтик-ККМ
- дистрибутив скачан с официального сайта разработчика http://www.kors-soft.ru/
- Лайтик-ККМ установлен на ПК кассира.
- драйвер для ККМ (в данном конкретном случае для АТОЛ 55Ф) взят с сайта разработчика программы. На момент написания статьи программа Лайтик-ККМ поддерживала работу с АТОЛ 1Ф, АТОЛ 11Ф, АТОЛ 15Ф, АТОЛ 20Ф, АТОЛ 22Ф / FPrint-22 ПТК, АТОЛ 25Ф, АТОЛ 27Ф, АТОЛ 30Ф, АТОЛ 42ФC, АТОЛ 50Ф, АТОЛ 52Ф, АТОЛ 55Ф, АТОЛ 60Ф, АТОЛ 77Ф, АТОЛ 91Ф (если разблокирован режим фиск.регистратора), АТОЛ 92Ф (если разблокирован режим фиск.регистратора), Казначей ФА.

Онлайн-кассы

Пользователь работает с программой 1С по протоколу RDP (терминальный режим). При подключении к серверу он "тянет" за собой локальный диск с папкой, в которой установлена программа "Лайтик-ККМ" (C\KorsSoft\Lit-kkm.35m\).

Онлайн-кассы

В программу 1С в два объекта конфигурации внесены небольшие изменения

1. В ПланВидовХарактеристик.НастройкиПользователей.Предопределенные добавлен новый вид характеристики "ЛайтикККМ" (тип Булево)

2. Процедура "ОсновныеДействияФормыОК(Кнопка)" модуля формы документа "ЧекККМ" после внесения изменений стала выглядеть следующи образом

Процедура ОсновныеДействияФормыОК(Кнопка)
Перем Ответ;
Перем Отказ;
Если ПровестиИРаспечататьЧек(Ответ, Отказ, ЭтаФорма) Тогда
//изменение_______________________________________________________________
Если УправлениеПользователями.ПолучитьЗначениеПоУмолчанию(глЗначениеПеременной(глТекущийПользователь), ЛайтикККМ) = Истина Тогда
Запись = Новый ЗаписьXML;
Запись.ОткрытьФайл(\\tsclient\C\KorsSoft\Lit-kkm.35m\check.xml,Windows-1251);
Запись.ЗаписатьОбъявлениеXML();
Запись.ЗаписатьНачалоЭлемента(check);
Для Каждого Строка Из ЭтотОбъект.Товары Цикл
Запись.ЗаписатьНачалоЭлемента(tovar);
//наименование товара
Запись.ЗаписатьНачалоЭлемента(tov_name);
Запись.ЗаписатьТекст(СокрЛП(Строка.Номенклатура));
Запись.ЗаписатьКонецЭлемента();
//цена
Запись.ЗаписатьНачалоЭлемента(tov_cen);
Запись.ЗаписатьТекст(СокрЛП(Строка.Цена));
Запись.ЗаписатьКонецЭлемента();
//количество
Запись.ЗаписатьНачалоЭлемента(tov_kol);
Запись.ЗаписатьТекст(СокрЛП(Строка.Количество));
Запись.ЗаписатьКонецЭлемента();
//тип ндс
Запись.ЗаписатьНачалоЭлемента(tov_tipnds);
Запись.ЗаписатьТекст(Строка(3));
Запись.ЗаписатьКонецЭлемента();
//тип товара
Запись.ЗаписатьНачалоЭлемента(tov_tiptov);
Запись.ЗаписатьТекст(Строка(1));
Запись.ЗаписатьКонецЭлемента();
Запись.ЗаписатьКонецЭлемента();
КонецЦикла;
Запись.ЗаписатьКонецЭлемента();
Запись.Закрыть();
//конец изменений_______________________________________________________________
КонецЕсли;
Закрыть();
Иначе
Предупреждение(?(Отказ, Возможны расхождения ИБ и ленты ФР! , ) + Ответ);
КонецЕсли;
КонецПроцедуры // ОсновныеДействияФормыОК()

При проведении документа "Чек" (в 1С) в каталоге программы "ЛайтикККМ" формируется файл "check.xml". Данные из файла в документ (в Лайтик-ККМ) передаются через опцию "Импорт чека (XML)" . Для удобства работы кассира был установлен второй небольшой монитор, а рабочий стол расширен на два монитора, В окне одного из них отображалась программа 1С, а в окне второго программа "Лайтик-ККМ"

Отдельное спасибо разработчикам программы "Лайтик-ККМ". Хочется верить в то, что когда-нибудь монополизму 1С на рынке делового софта наступит конец. С каждым годом решения от 1С становятся все более сложными в плане внедрения, сопровождения и работы.

При использовании материалов сайта активная ссылка на источник обязательна

Новости Воронежской области

Аннинский, Панинский и Эртильский районы Воронежской области: вчера, сегодня, завтра

Каталог публикаций