Организация работы с филиалами в программе 1С Торговля и Склад 7.7

подслушано в Аннинском районе:
«Продимекс» выкупил земельные активы «Талекса» в Аннинском и Панинском районах
Конфигурация Торговля и Склад 7.7, несмотря на значительное изменение конъюнктуры, продолжает использоваться во многих организациях, особенно на предприятиях малого и среднего бизнеса. Одной из проблем в организации оперативного учета сегодня является работа с филиалами или обособленными подразделениями, когда плательщиком выступает одно лицо, а грузополучателем совершенно другое. Если грузополучатель – полноценное юридическое лицо со своим ИНН, юридическим и фактическим адресом, то в этом случае печать ТОРГ-12 и счет-фактуры реализуется с помощью внешних печатных форм с выбором грузополучателя.

Но как быть, если у филиалов, например, сети розничных магазинов, одно и то же юридическое лицо и один и тот же юридический адрес, хотя фактические адреса различны. В этом случае в формах ТОРГ-12 и счет-фактуры типового решения в графу грузополучатель на печать выводится фактический адрес юридического лица, а не адрес местонахождения филиала.

Справочник «Филиал»

Создаем в конфигураторе новый подчиненный справочнику «Контрагенты» справочник «Филиал» и заводим в этом справочник новые реквизиты (ПолноеНаименование и ФактическийАдрес – строки неограниченной длины, остальные реквизиты – строки фиксированной длины). В модуль формы элемента добавляем следующий код

Перем ФактАдрес;
Перем ЮрАдрес;
Процедура ПоКнопкеВводаАдреса(Адрес1, Адрес2)
глВводАдреса(Адрес1);
Если ПустаяСтрока(глПредставлениеАдреса(Адрес2)) = 1 Тогда
Адрес2 = Адрес1;
КонецЕсли;
ФактическийАдрес = глПредставлениеАдреса(ФактАдрес);
КонецПроцедуры // ПоКнопкеВводаАдреса()

Справочник «Проекты»

В справочник «Проекты» добавляем новый реквизит «Филиал» (тип Справочник.Филиал). В модуль формы элемента справочника добавляем процедуру ПриЗаписи()

Процедура ПриЗаписи()
Если ПустоеЗначение(Наименование)=1 Тогда
Если ПустоеЗначение(Филиал)=0 Тогда
Наименование = СокрЛП(Филиал);
Иначе
Предупреждение("Не заполнено поле ""Наименование""!", 60);
Активизировать("Наименование");
СтатусВозврата(0);
КонецЕсли;
КонецЕсли;
КонецПроцедуры

Документ «Реализация»

подслушано в поселке Анна:
Численность крупного рогатого скота в Аннинском районе составляет более 18 тысяч голов
В модуль формы документа «Реализация» в процедуру Печать(СразуНаПринтер = 0,КолЭкз = 1,БезУслуг = 0) добавить следующий код

Если ПустоеЗначение(Проект) = 0 Тогда
ПечГрузополучатель = СокрЛП(Проект.Филиал.ПолноеНаименование) +
?(ПустоеЗначение(Проект.Филиал.ФактическийАдрес) = 0, ", " + Проект.Филиал.ФактическийАдрес, "")+
?(ПустоеЗначение(КлиентРеквизиты) = 0, ", " + КлиентРеквизиты, "");
Иначе
ПечГрузополучатель = Клиент +
?(ПустоеЗначение(КлиентФактАдрес) = 0, ", " + КлиентФактАдрес, "")+
?(ПустоеЗначение(КлиентРеквизиты) = 0, ", " + КлиентРеквизиты, "");
КонецЕсли;

Справочник «Контрагенты

В справочнике «Контрагенты» на форму элемента в слой «Кнопки» добавим кнопку «Филиал» и свяжем ее с событием ОткрытиеСправочникаФилиалы(), а в модуль формы элемента добавим эту процедуру

Процедура ОткрытиеСправочникаФилиалы()
НаименованиеВОткрываемуюФорму = ТекущийЭлемент();
ОткрытьФорму("Справочник.Филиал",НаименованиеВОткрываемуюФорму);
КонецПроцедуры

Настройки в режиме 1С: Предприятие

Конфигурировать больше ничего не надо. Далее в режиме 1С:Предприятие для контрагентов, у которых есть сеть филиалов по кнопке «Филиал» заводим подчиненные элементы справочника.

В справочнике «Проекты» регистрируем проекты с привязкой к филиалам.

Теперь при печати ТОРГ-12, если проект будет выбран на форме документа «Реализация», то в печатной форме в графе «Грузополучатель» будет отображаться фактический адрес филиала, а не юридического лица.

Для печатной формы счет-фактуры просто подключите внешнюю печатную форму, которую может скачать здесь и при выборе проекта на форме документа «Счет-фактура выданный» форме в графе «Грузополучатель» будет отображаться фактический адрес филиала, а не юридического лица

все материалы текущего раздела